Installing the Atermiter X79 turbo motherboard

Atermiter X79 motherboard with a be quiet CPU cooler and Gskill Ripjaws RAM

The new equipment - Atermiter X79 turbo motherboard

Back on July 17th I wrote about buying the Atermiter X79 turbo motherboard. After a couple of brief delays due to postal routing issues the motherboard arrived yesterday (from China). This is what was involved in replacing my existing workstation with this new motherboard and a XEON E5-1650 processor.

Why upgrade? Why I didn't buy a new Ryzen system?

The current generation of Ryzen processors are very appealing. A Ryzen 5 3600X can currently be picked up for $299CDN (on sale from $339), just $20 more than the non-X variant. At the time I'm writing this the Ryzen 5 3600X has a Passmark benchmark of 18326, putting at the 134th overall spot for processing power. This might not seem very good to those who don't pay attention to benchmarks, but my old 3.6GHz (3.9GHz turbo) A8-5600K APU has an overall Passmark rank of 1258 with a meagre benchmark of 2710. While the $299CDN price is a bit more than I'd like to pay, I didn't rule it out because of price. The real problem is I have no current generation equipment, which means I'd be buying a new CPU, a new motherboard, and new RAM. Even if I was very cheap I likely wouldn't have spent less than $450CDN.

The other factor in this was curiosity: PhilsComputerLab, Tech Yes City, Linus Tech Tips, Gamers Nexus, and Craft Computing have all done videos on new socket LGA2011 "X79" motherboards purchased from various Chinese sellers on AliExpress/Ebay/Amazon. To be clear LGA2011 is an old socket first introduced in 2011 (before my APU), but these motherboards are newly manufactured in China. As far as I know there are no computer stores carrying these motherboards in North America. The design of these motherboards is new and features some features, like m.2 support, that didn't come in the original socket LGA2011 motherboards.

The old equipment - A8-5600K APU-based workstation

The main computer I used since 2013 had an AMD A8-5600K APU at its core. Back in late 2013 the A8-5600K was one of the best value deals. It was marketed as a 4 core CPU it wasn't a true 4 core processor: see this notebookcheck article (warning: ads): https://www.notebookcheck.net/AMD-A-Series-Desktop-AMD-A8-5600K-Processor.91972.0.html. I felt the A8-5600K really was a great processor back in 2013, but both my wife and son have had better Intel Core i5-based systems for several years, so I started feeling the want for something a bit better.

My old motherboard was a Gigabyte F2A85XM-D3H motherboard. It was fine for a few years, but a couple of years ago I tried supporting dual monitors and I ran into random reboots (both on Windows and Linux, particularly when running intensive applications like trying to stream on Twitch). Replacing the power supply with a brand new EVGA 600W PSU helped, but didn't stop the reboots completely. Because they only happened when trying to run dual monitors I looked to the video card next, but that didn't solve the issue either. It's possible it's the A8-5600K APU, but I suspect it's the motherboard.

Back in 2013 I selected 16GB of GSkill RipJaws RAM running at 1866MHz. The Gigabyte motherboard has some blue on it so I decided to pick up the RAM with the blue heat shield. Buying the RAM with the blue heat shield turned out to be a bad decision as when I went to buy more RAM a couple of years later only the RAM with the red heat shield was available in that speed (thus the mismatched RAM in the photo).

Over the years I've added a couple of SSDs (a 250GB for Windows and a 500GB for Linux). I even purchased a copy of Windows 8.1 back in 2013 that I later upgraded to Windows 10.

Shipping issues

The biggest shipping concern I has was whether the package would arrive in good condition. The Atermiter store processed the order right away, but it seemed to sit for about 8 days before it got shipped out. Not long after I got a notice with some tracking information. I was able to see when the package left China. I also got a notice when the package arrived in British Columbia, Canada, along with more tracking information. If I'm remembering correctly it arrived in Canada July 29, 2020, so it took a little more than 2 weeks to get to me once it arrived in Canada (it took less time to get from China to B.C., Canada than it did to reach me here in Ontario, Canada). To Canada Post's credit they sent me an "oops, we messed up routing your order" email, and followed it up by a couple of other emails before the package finally reached me.

Atermiter X79 turbo box within a damaged shipping box

The outer packaging was slightly creased, as if something heavy was sat on top of it. I was a bit concerned that the motherboard got damaged. Who do you go after in that situation? Thankfully the Atermiter store packed the motherboard in a box within another box. I looked over the motherboard and it appeared in great condition.

LGA2011 Cooling

The Atermiter store and a number of other stores sell heat sink and fan solutions for LGA2011 motherboards. Not knowing what to expect I opted to buy a cooling solution from a local computer store. After a lot of looking at both AIO water coolers and CPU fans and heat sinks I decided to buy the BeQuiet Shadow Rock Slim.

BeQuiet Shadow Rock Slim CPU cooler

I considered using using the Cooler Master Hyper 212 since I had one on the A8-5600K APU, but I'm glad I chose to buy the Shadow Rock Slim - it's a more impressive looking cooler and was very easy to install. Temperature for the E5-1650 was at 41 Celsius under a small load - Xubuntu with Firefox, Steam, and a couple of other applications open. Another great thing about Shadow Rock Slim is that there's lots of room for big RAM on this Atermiter motherboard - my Ripjaws RAM all fit nicely without having to adjust anything (which was not the case with the Hyper 212 on my AMD board).

Oops, out of thermal paste

I had a tube of Arctic Silver thermal paste in my tool drawer, but I didn't realize there was so little left that there wasn't enough to even put a pea-size amount of paste on the LGA2011-based CPU (which is a fair-size). BeQuiet included a tube of thermal paste with the Shadow Rock Slim, so that problem was taken care of.

No battery

When any company on AliExpress ships out of China they cannot include a CMOS battery. I simply removed the battery from my Socket FM2 motherboard and used it.

Front Panel USB 3.0

The cable that goes from the Antec Three Thousand and Two case to the USB 3.0 header on the Atermiter motherboard just barely reached, and I mean just barely. Any shorter and it would not have reached. I have since tested the front ports with a USB 2.0 key and it works. I've yet to test speeds on the USB 3.0 port to see if I'm getting USB 3.0 speeds.

RAM running at the slowest speed (1066MHz)

When I got my Socket FM2 motherboard I really didn't expect I'd upgrade my 16GB of RAM. When I did upgrade I couldn't buy the same 1866MHz GSkill RAM with the blue heat sink. The RAM I got ended up being slightly slower CL timings. This was fine in the Socket FM2 motherboard, XMP boosted the memory to 1866MHz even though timings were different. The Atermiter board appears to be a bit more fussy, it likes the blue 1866MHz RAM with better timings a bit better than the red GSkill 1866MHz RAM. As a result the blue shielded RAM is getting down-clocked by the red shielded RAM, but neither is operating at 1866MHz.

Blue and red 1866MHz GSkill Ripjaws RAM on Socket FM2 motherboard

Part of the problem is there's no simple XMP profile to load and I'm unfamiliar with RAM tuning BIOS options. With a bit more research I might be able to get the RAM running faster. I could take the red RAM out, but I'd have 1/2 the RAM and would run in dual channel (it's running in quad channel right now). I may end up just buying 4 x 16GB 1600MHz ECC RAM from AliExpress (1866MHz is expensive enough that I'm not sure it's worth the extra MHz considering I'm mostly doing video encoding and light gaming).

First POST - nothing

When I first tried powering on the motherboard I got nothing, no beeps, no lights, nothing. At that point I had the side panel open and decided to press the power button on the motherboard, it POSTed fine. It turns out I had the front panel cables connected incorrectly. The motherboard didn't come with a manual and only had colours to indicate what goes where. Unfortunately these colours didn't match most of the suggested front panel schemes on Google. I found a diagram that did work on this (Russian) web site: https://xeon-e5450.ru/dwqa-question/podskazhite-pozhalujsta-raspinovku-dlya-perednej-paneli-plexhd-x79-turbo/. Once I connected things up according to this diagram things worked as expected.

Everything works

Xubuntu 20.04 booted first time with no issues. I didn't reinstall, didn't change any settings from my Socket FM2 motherboard, it "just worked." Windows 10 did it's updating drivers, and rebooted several times, but it too worked fine. I ran Cinebench under Windows and it was noticeably faster than my old system. Even running apt get update under Xubuntu was noticeably faster - that's the gulf of difference between the 4 core A8-5600K APU and the 6 core E5-1650. It's worth mentioning this is a V1 E5-1650 CPU. Version 2 of the E5-1650 CPU is even faster (but not worth the extra money in my opinion).

Handbrake Encoding

The big test, the only test that I felt really mattered was the handbrake compression test. I've talked about my methodology earlier in this article on Video encoding across 3 older systems. Basically I use a command line version of handbrake with some presets to compress files I've dumped using MakeMKV. I have a BASH shell script that runs handbrake-cli with those presets and it encodes every video I put in a particular folder. Here are the results from the old article with the E5-1650 tacked on at the end:

Pentium 4 2.4GHz - Average Frames Per Second: 7.59
A8-5600K APU 3.6GHz - Average Frames Per Second: 66.83
i7-2600 CPU - Averge Frames Per Second: 126.81
E5-1650 CPU - Averge Frames Per Second: 179.22

The E5-1650 CPU finished encoding the same file more than 5 minutes faster than the Core i7-2600 CPU, and almost 21 minutes faster than the A8-5600K APU. The Pentium 4 was over 4 hours and 21 minutes slower. If you're on a Pentium 4 trying to do video encoding almost anything more modern will probably help.

Atermiter Surprises

I'm very pleased with the Atermiter X79 turbo motherboard despite the fact that there's no motherboard manual and I haven't nailed down the RAM timings. I was really pleased with the layout of things on the motherboard, though I know that when I buy an m.2 drive I'm going to have to pull the graphics card. (Which reminds me there was about 10cm of clearance between the heat sink and graphics card).

Atermiter X79 turbo motherboard with BeQuiet Shadow Rock Slim cooler installed

I spent at least 5 minutes on the Socket FM2 motherboard trying to get the 8 pin power connector detached. Trying to jam my fingers between the Cooler Master 212 and the system unit case to pull off the 8 pin connector was painful. Plugging the same 8 pin connector into the Atermiter board was a breeze and looked better because I could cable manage a bit better.

Perhaps the biggest surprise for me was the difference when running apt get update && apt get -y upgrade on the new system. I did not expect there to be a noticeable difference, but there was.

The future - storage, video card, maybe a new case

What's next for my workstation? I'm probably done for a little while. An m.2 NVME SSD would be nice, but since everything worked so perfectly when I connected it all up I'm almost dreading adding something that would require a re-installation. I'm not sure cloning would work since block device ID's would change and fstab would likely need to be updated. I don't really need a new graphics card, but I wonder if handbrake's AMD extensions would further cut down the time if I had an RX580?

A new case might be the next purchase, but I haven't been able to find a case that ticks all the boxes I need: DVD/Blu-ray 5 1/4" slot, at least 4 x 3.5" slots, 2 x SSD slots and nice esthetics.

 

Comments

Submitted bycharm on Sat, 10/31/2020 - 21:27

Just an update after a couple of months of use of the Atermiter X79 Turbo motherboard. I believe the network chipset on the motherboard is NOT gigabit, but 10/100MB. It's a bit insane considering all the other features on this board, but transfer speeds of files using Filezilla to our KODI server have hovered around 5.9 MB/s compared to the 70+ MB/s we were getting on the old Socket FM2 motherboard (which did have a gigabit LAN connector).

I can pick up a Gigabit LAN connector, but it's a bit sad that I have to do this with this board, a board that offered a lot more in other areas.

Thanks to @Manu on Youtube for reminding me I should follow up this comment. My network speed issue turned out NOT to be the fault of the Atermiter X70 Turbo Motherboard. Just after installing the motherboard I also spent some time cleaning up our networking. I shortened a very long Cat5e, using some ends that were so large they barely fit in the network jack (I've never had an issue with large connectors before - these ones were bought at a clearance store and I didn't notice they were slightly larger than normal RJ45 connectors). When I replaced the ends my network speed shot back up.

I just finished a 4.6GB transfer between this system and our KODI entertainment system in the living room and the transfer hovered around 74.5MB/s for most of the transfer. At one point it hit over 81MB/s, but it dropped down to 69MB/s just before the end. The network jack does seem a tiny bit slower, but this may just be this one case - another file (larger/smaller) might yield a different result.

Atermiter X79 turbo speed transferring